HELP pro program EP

Elektronické podání dokladů na ČSSZ

(c) 2005 Helpsoft spol. s r. o.


Úvodní informace

Program "ep.exe" (zkratka slov elektronické podání) slouží k podání souboru ELDP (evidenčních listů důchodového pojištění) nebo přihlášek k nemocenskému pojištění na ČSSZ přes Portál veřejné správy.

Vstupem do programu je soubor evidenčních listů nebo přihlášek typu xml ve struktuře definované ČSSZ ( http://www.cssz.cz/tiskopisy/ELDP_2004/datova-veta-reldp.asp a http://www.cssz.cz/nemocenske/prihlasky/definice.asp). Program soubor převezme, překóduje do UTF-8, elektronicky podepíše, zašifruje a odešle na adresu ČSSZ. Pro podpis a šifrování používá funkce CAPICOM.

Všechny potřebné informace k předávání dokladů přes Portál veřejné správy nalezne uživatel na stránkách ČSSZ - http://www.cssz.cz ve volbách
- "Evidenční listy důchodového pojištění pro období po 1.1.2004" a
- "Přihlášky zaměstnanců k nemocenskému pojištění, odhláška - platné od 1.7.2005".

DEMO verze, která se dá stáhnout z Internetu je plně funkční verzí programu, má omezení pouze na počet přenášených záznamů (maximálně 2) a počet přenosů (pouze 1). Dá se tedy vyzkoušet pro ověření správnosti přenosu.
Důležité je, že záznamy poslané v rámci ověření přenosu se musí z následujícího přenosového souboru vyřadit. Jeden evidenční list nebo přihláška se nesmí poslat víckrát !!!


Registrace

Registrace je povinná, pokud chcete přejít na plnou funkci programu.

Je třeba vyplnit registrační formulář a poslat vytvořený soubor "ep.reg" na mailovou adresu eldp@helpsoft.cz.

Dostanete zpět e-mail obsahující potvrzení přijetí Vaší registrace a pokyny k zaplacení registračního poplatku. Poté, co přijde příslušná částka na uvedený účet, bude Vám zaslán soubor "ep.bin". Tento soubor nahrajete do adresáře programu Ep a při následujícím spuštění programu již bude program plně funkční.


Funkce programu

Tato sekce vysvětluje funkce jednotlivých menu voleb a tlačítek programu:

RELDP:
Vytvořit soubor k odeslání
Zobrazit soubor k odeslání
Odeslat požadavek
Servis
Zjistit zbytkové požadavky
Sledovat zpracování zbytkových požadavků
Zobrazit protokol
Smazat protokol
Konfigurace...
Registrace...
O programu...


Vytvořit soubor k odeslání

1. | Nejprve si vyberete druh záznamů, které budete chtít předat: - ELDP - Přihlášky k nemocenskému pojištění
2. | Pak si vyberete vstupní soubor s daty.
3. | Dalším krokem je výběr certifikátu pro elektronický podpis a certifikátu pro zašifrování dat.
4. | Program překóduje data ze vstupního souboru do UTF-8 (z důvodů bezproblémového přenosu), pak je elektronicky podepíše, zašifruje a vytvoří v aktuálním adresáři přenosový soubor "ep_snd.xml".


Zobrazit soubor k odeslání

Ve zvláštním okně zobrazí obsah souboru "ep_snd.xml" vytvořeného v Vytvořit soubor k odeslání .


Odeslat požadavek

Zahájí přenos obsahu soubor ep_snd.xml a sleduje jeho zpracování.

Zpracování začíná vysláním požadavku SUBMISSION_REQUEST (obsah souboru ep_snd.xml) a získáním odpovědi, která může být trojího druhu:
SUBMISSION_ACKNOWLEDGEMENT - požadavek je přijat a zpracovává se,
SUBMISSION_ERROR - požadavek skončil chybou a
SUBMISSION_RESPONSE - požadavek byl úspěšně zpracován.

Pokud se vrátí SUBMISSION_ACKNOWLEDGEMENT, pokračuje zpracování opakovaným vysíláním dotazu na stav zpracování (SUBMISSION_POLL) a přijímání odpovědí do chvíle, kdy se vrátí SUBMISSION_ERROR nebo SUBMISSION_RESPONSE a nebo se desetkrát vrátí odpověď SUBMISSION_ACKNOWLEDGEMENT. V tomto případě má klient možnost sledování požadavku přerušit a vrátit se k němu později.

Pokud se vrátí SUBMISSION_ERROR nebo SUBMISSION_RESPONSE, dokončí se zpracování požadavku tím, že se požadavek na serveru zruší (DELETE_REQUEST - následuje zpravidla potvrzení zrušení DELETE_RESPONSE). Výsledek zpracování navíc klient dostane elektronickou poštou na adresu, kterou udal při své registraci na ČSSZ. V této poště je potvrzení přijetí nebo podrobně popsaná chyba, kterou přenos skončil.


Zjistit zbytkové požadavky

Každý odeslaný požadavek (SUBMISSION_REQUEST) zůstává na cílovém serveru, dokud se nezruší příkazem DELETE_REQUEST ( Odeslat požadavek ).

Tato funkce vyšle požadavek DATA_REQUEST pro předem vybraný druh přenosu (ELDP / Přihlášky). Jeho odpovědí je seznam všech požadavků klienta, které zůstávají nesmazány na serveru (jejich jednoznačných identifikátorů), spolu s jejich stavem a datem a hodinou vytvoření.

Tento seznam zobrazí a klient může selektivně požadavky ze serveru zrušit.


Další sledování vybraného požadavku

Sledovat zpracování zbytkových požadavků

Pro zadaný druh přenosu (ELDP / Přihlášky) vyšle příkaz DATA_REQUEST a zjistí všechny zbytkové požadavky na serveru. Z nich vybere ty, které jsou ve stavu SUBMISSION_ACKNOWLEDGE a zobrazí jejich identifikátor spolu s časem zaznamenání požadavku.

Klient si pak může vybrat požadavek, jehož zpracování chce dále sledovat. ( Odeslat požadavek )


Zobrazit protokol

Ve zvláštním okně zobrazí obsah logového souboru "ep.log", ve kterém se průběžně protokoluje práce programu.


Smazat protokol

Funkce smaže z disku celý logový soubor "ep.log".


Konfigurace

V tomto formuláři musí uživatel vyplnit hodnoty parametrů potřebných k elektronickému přenosu.
Jde o následující parametry:

Variabilní symbol | - ten má každý klient ČSSZ přidělen od chvíle svého přihlášení
e-mail adresa | - tady klient napíše adresu, kterou uvedl na krajské správě ČSSZ, když se registroval k přenosům evidenčních listů
Uživatelská identifikace | - toto je dvanáctimístný identifikátor, který klient obdržel jako výsledek své elektronické registrace na Portálu veřejné správy
Heslo | - jde o heslo, které klient uvedl při své registraci na Portálu veřejné správy
Všechny tyto čtyři parametry musí být vyplněny, aby byly přístupné všechny funkce programu.

Dále musí uživatel uvést, zda používá pro připojení server proxy a pokud ano, vyplnit potřebné parametry.

Adresa a port | - tyto dva údaje nejsou povinné. Pokud je uživatel nevyplní, přebírají se z nastavení default internetového browseru. Pokud je uživatel vyplní, musí vyplnit oba dva.
Uživatel a heslo | - tyto dva údaje jsou povinné


Registrace...

Registrační formulář obsahuje několik položek, které musíte vyplnit. Povinné jsou pouze položky označené hvězdičkou:
- IČ
- DIČ pokud jste plátci daně z přidané hodnoty
- název organizace
- fakturační adresa
- e-mailová adresa pro další komunikaci
Pro jednodušší komunikaci doporučujeme vyplnit i telefonní číslo a jméno kontaktní osoby.

Důležité pro registraci je vybrat instalovaný certifikát, který budete používat pro elektronický podpis podávaných evidenčních listů.